Fulfilled Messianic Prophecies
[So Far]

Claiming to predict the future is an endeavor that almost no "religious text" other than the Bible will attempt. The obvious reason is the writers or "gods" behind these texts have no power to know the future. These texts [Koran, Book of Mormon, Book of the Dead, etc.] make great claims and supposedly reveal great truths, but they contain no prophecy unique to them to establish these "truths." The Holy Bible, however, does not suffer from these weaknesses. It flawlessly and accurately predicts future events hundreds of times without failure. Fulfilled prophecy is one of the major proofs that the Bible is [not contains] the very words of the Living God: the creator of all things and the Father of the Lord Jesus Christ and all who believe on Him. When the Lord writes a book He places traits and proofs among His words that no man or devil can duplicate.

Below is a sample of the Lord's predictions concerning the first coming of His son Jesus Christ. There are 200 or so listed, each with a reference to the prophecy and its fulfillment. A study of these references will reveal to the seeking soul that the Bible is a unique book and like no other. To an honest seeker these prophecies prove the divine nature of the Bible. To a believer they reassure him of the truth of God's word in these times of doubt. They are infallible.

The believer should notice that these prophecies are not vague, indefinite predictions that leave room for "spiritualization" or "interpretation." They are specific predictions with specific fulfillments. This indicates the way a person is to approach the Bible. One is not to treat is as a book of general truths open to interpretation as is so common today. It is to be treated as the literal and specific words of the God of creation to mankind.

This list deals with messianic prophecies that have already been fulfilled. It does not mention the prophecies that are yet to be fulfilled at Christ's second coming. However, the fulfillments of the past foreshadow the fulfillments of the future. That Christ will one day stand upon the Mount of Olives as a conquering warrior in bloody garments [Isa. 63:3-4] is as certain a fact as His hanging on a cross as a lamb.

Genesis | Prophecy | Fulfillment
The Messiah would be born of the "seed" of a woman. | Gen. 3:15 | Luke 1:34-35
The Messiah would defeat Satan. | above | 1John 3:8
The Messiah would suffer while reconciling men to God. | above | 1Pet. 3:18
The Messiah would be a descendant of Shem. | Gen. 9:26 | Luke 3:36
The Messiah would be a descendant of Abraham. | Gen. 12:3 | Matt. 1:1
The Messiah would be a descendant of Isaac. | Gen. 17:19 | Luke 3:34
The Messiah would be a descendant of Abraham. | Gen. 18:17-18 | Matt. 1:1
The Messiah would come for all nations. | above | Acts 3:24-26
The Messiah would be a descendant of Isaac. | Gen. 21:12 | Luke 3:34
Messiah to be sacrificed on the same mountain where God tested Abraham. | Gen. 22:14 | Luke 23:33
The Messiah would be a descendant of Abraham. | Gen. 22:18 | Gal. 3:16
The Messiah would come for all nations. | above | Gal. 3:14
The Messiah would be a descendant of Isaac. | Gen. 26:4 | Luke 3:34
The Messiah would be a descendant of Jacob. | Gen. 28:14 | above
The Messiah would come for all people. | above | Gal. 3:26-29
The Messiah would be a descendant of Judah. | Gen. 49:10 | Luke 3:33
The Messiah would be a King | above | John 1:49
The Jew's capitol punishment authority would be gone when the Messiah arrived. | above | John 18:31
Numbers |  |
The Messiah would be a King. | Num. 24:17 | John 19:19
Deuteronomy |  |
The Messiah would be a Prophet. | Deut. 18:15-19 | John 6:14
The Messiah would speak with words of authority given to Him from God. | above | John 12:48-50
Those who refused to listen to the Messiah would be judged. | above | above
The Messiah would be worshiped by angels at his birth. | Deut. 32:43 | Luke 2:13-14
Ruth |  |
The Messiah would be a descendant of Boaz & Ruth. | Ruth 4:12-17 | Luke 3:32
1 Samuel |  |
The Messiah would be exalted by God with power and strength. | 1Sam. 2:10 | Matt. 28:18
2 Samuel |  |
The Messiah would be a descendant of David. | 2Sam. 7:12-13 | Matt. 1:1
The Messiah would be the Son of God. | above | Matt. 3:16-17
The Messiah would be a descendant of David. | 2Sam. 7:16 | Matt. 1:1
The Messiah would come for all people. | 2Sam. 22:50 | Rom. 15:8-9
The Messiah would be the "Rock." | 2Sam. 23:2-4 | 1Cor. 10:4
The Messiah would be as the "light of the morning." | above | Rev. 22:16
1 Chronicles |  |
The Messiah would be a descendant of Judah. | 1Chron. 5:2 | Luke 3:33
The Messiah would be a descendant of David. | 1Chron. 17:11-12 | Luke 3:31
The Messiah's throne would be everlasting. | above | Luke 1:32-33
The Messiah would be the Son of God. | 1Chron. 17:13-14 | Matt. 3:16-17
Psalms |  |
The Messiah would be rejected by Gentiles. | Psa. 2:1 | Acts 4:25-28
Political and religious leaders would conspire against the Messiah. | Psa. 2:2 | Matt. 26:3-4
The Messiah would be a King. | Psa. 2:6 | John 12:12-13
The Messiah would be the Son of God. | Psa. 2:7 | Luke 1:31-35
The Messiah would declare that he was the Son of God. | above | John 9:35-37
The Messiah would be resurrected and crowned as King. | above | Acts 13:30-33
The Messiah would ask God for His inheritance. | Psa. 2:8 | John 17:4-24
The Messiah would receive authority over all. | above | Matt. 28:18
The Messiah would be the Son of God. | Psa. 2:12 | Matt. 17:5
The Messiah would reject those who did not believe in him. | above | John 3:36
Infants would give praise to the Messiah. | Psa. 8:2 | Matt. 21:15-16
The Messiah would be given authority over all things. | Psa. 8:6 | Matt. 28:18
The Messiah would be resurrected. | Psa. 16:8-10 | Matt. 28:6
The Messiah's body would not be subject to decay. | above | Acts 13:35-37
The Messiah would be exalted to the presence of God. | Psa. 16:11 | Acts 2:33
The Messiah would come for all people. | Psa. 18:49 | Eph. 3:4-6
The Messiah would cry out to God. | Psa. 22:1 | Matt. 27:46
The Messiah would be forsaken by God. | above | Mark 15:34
The Messiah, anguished, would pray without ceasing. | Psa. 22:2 | Matt. 26:38-39
The Messiah would be despised. | Psa. 22:6 | Luke 23:21-23
The Messiah would be mocked by people shaking their heads. | Psa. 22:7 | Matt. 27:39
Mockers would say of the Messiah, "he trusted God, let him deliver him." | Psa. 22:8 | Matt. 27:41-43
The Messiah would be aware of his Father from his youth. | Psa. 22:9 | Luke 2:40
The Messiah would be called to God's service from the womb. | Psa. 22:10 | Luke 1:30-33
The Messiah would be abandoned by the disciples. | Psa. 22:11 | Mark 14:50
The Messiah would be surrounded by evil spirits. | Psa. 22:12-13 | Col. 2:15
The Messiah's heart would burst, flowing with blood & water. | Psa. 22:14 | John 19:34
The Messiah would be crucified. | above | Matt. 27:35
The Messiah would thirst. | Psa. 22:15 | John 19:28
The Messiah would thirst shortly before his death. | above | John 19:30
The Messiah would be surrounded by Gentiles at his crucifixion. | Psa. 22:16 | Luke 23:36
The Messiah would be surrounded by Jews at his crucifixion. | above | Matt. 27:41-43
The Messiah's hands and feet would be pierced. | above | Matt. 27:38
None of the Messiah's bones would be broken. | Psa. 22:17 | John 19:32-33
People would stare at the Messiah during his crucifixion. | above | Luke 23:35
The Messiah's garments would be divided. | Psa. 22:18 | John 19:23-24
Lots would be cast for the Messiah's clothes. | above | above
The Messiah's atonement would enable believers to be his brethren. | Psa. 22:22 | Heb. 2:10-12
None of the Messiah's bones would be broken. | Psa. 34:20 | John 19:32-33
The Messiah's offering of himself would replace all sacrifices. | Psa. 40:6-8 | Heb. 10:10-13
The Messiah would say the scriptures were written of him. | above | Luke 24:44
The Messiah would come to do God's will. | Psa. 40:7-8 | John 5:30
The Messiah would not conceal his mission from the congregation. | Psa. 40:9-10 | Luke 4:16-21
The Messiah's betrayer would be a friend whom he broke bread with. | Psa. 41:9 | Mark 14:17-18
The Messiah would speak with a message of grace. | Psa. 45:2 | Luke 4:22
The Messiah's throne would be everlasting. | Psa. 45:6-7 | Luke 1:31-33
The Messiah would be God. | above | Heb. 1:8-9
The Messiah would act with righteousness. | above | John 5:30
The Messiah would ascend into heaven. | Psa. 68:18 | Luke 24:51
The Messiah would give gifts to men. | above | Matt. 10:1
The Messiah would be hated by many without cause. | Psa. 69:4 | Luke 23:13-22
The Messiah would bear reproach, for God's sake. | Psa. 69:7 | Matt. 26:65-67
The Messiah would be rejected by the Jews. | Psa. 69:8 | John 1:11
The Messiah's brothers would disbelieve him. | above | John 7:3-5
The Messiah would be angered by disrespect toward the temple. | Psa. 69:9 | John 2:13-17
The Messiah would bear reproach, for God's sake. | Psa. 69:9 | Rom. 15:3
The Messiah's disciples would fail him in his time of need. | above | Mark 14:33-41
The Messiah would be offered gall and vinegar. | Psa. 69:21 | Matt. 27:34
The Messiah would thirst. | above | John 19:28
The potters field would be uninhabited. | Psa. 69:25 | Acts 1:16-20
The Messiah would speak in parables. | Psa. 78:2 | Matt. 13:34-35
The Messiah would be at the right hand of God. | Psa. 80:17 | Acts 5:31
The Messiah would be a descendant of David. | Psa. 89:3-4 | Matt. 1:1
The Messiah would call God his Father. | Psa. 89:26 | Matt. 11:27
The Messiah would be God's "firstborn." | Psa. 89:27 | Mark 16:6
The Messiah would be a descendant of David. | Psa. 89:29 | Matt. 1:1
The Messiah would be a descendant of David. | Psa. 89:35-36 | Matt. 1:1
The Messiah would be eternal. | Psa. 102:25-27 | Col. 1:17
The Messiah would be the creator of all. | above | John 1:3
The Messiah would be accused by false witnesses. | Psa. 109:2 | John 18:29-30
The Messiah would pray for his enemies. | Psa. 109:4 | Luke 23:34
The Messiah's betrayer would have a short life. | Psa. 109:8 | Acts 1:16-18
The Messiah's betrayer would be replaced. | above | Acts 1:20-26
The Messiah would be mocked by people shaking their heads. | Psa. 109:25 | Mark 15:29-30
The Messiah would be Lord. | Psa. 110:1 | Matt. 22:41-45
The Messiah would be at the right hand of God. | above | Mark 16:19
The Messiah would be a Priest in the order of Melchisedec. | Psa. 110:4 | Heb. 6:17-20
The Messiah would be at the right hand of God. | Psa. 110:5 | 1Pet. 3:21-22
The Messiah would be the "stone" rejected by the Jews. | Psa. 118:22 | Matt. 21:42-43
The Messiah would come in the name of the Lord. | Psa. 118:26 | Matt. 21:9
The Messiah would be a descendant of David. | Psa. 132:11 | Matt. 1:1
The Messiah would be a descendant of David. | Psa. 132:17 | above
Proverbs |  |
The Messiah would be from everlasting. | Pro. 8:22-23 | John 17:5
The Messiah would ascend and descend from heaven. | Pro. 30:4 | John 3:13
God would have a Son. | above | Matt. 3:16-17
Isaiah |  |
The Jews would have a hardened heart against the Messiah. | Isa. 6:9-10 | John 12:37-40
The Messiah would speak in parables. | Isa. 6:9-10 | Matt. 13:13-15
The Messiah would be a descendant of David. | Isa. 7:13-14 | Matt. 1:1
The Messiah would be born of a virgin. | Isa. 7:14 | Luke 1:34-35
The Messiah would be Immanuel, "God with us." | above | Matt. 1:21-23
The Messiah would be God. | above | John 12:45
The Messiah would be a "stumbling stone" for the Jews. | Isa. 8:14 | Matt. 21:43-44
The Messiah would minister in Galilee. | Isa. 9:1-2 | Matt. 4:12-17
The Messiah would be a light to the Gentiles. | above | Luke 2:28-32
The birth of the Messiah. | Isa. 9:6 | Luke 2:11
The Messiah would be the Son of God. | above | Luke 1:35
The Messiah would be the "Wonderful Counselor." | above | John 7:46
The Messiah would be both God and man (the "Mighty God"). | above | John 10:30
The Messiah would be from everlasting (the "Everlasting Father"). | above | Rev. 1:8
The Messiah would be the "Prince of Peace." | above | Col. 1:20
The Messiah would be a descendant of David. | Isa. 9:7 | Matt. 1:1
The Messiah would be a descendant of Jesse. | Isa. 11:1 | Luke 3:23-32
The Messiah would grow up in a poor family. | above | Luke 2:7
The Messiah would have the full Spirit of God upon him. | Isa. 11:2 | Matt. 3:16-17
The Messiah would have the Spirit of Wisdom. | above | Luke 2:40
The Messiah would have the Spirit of Understanding. | above | above
The Messiah would have the Spirit of Counsel. | above | Matt. 7:28-29
The Messiah would have the Spirit of Might. | above | Matt. 8:27
The Messiah would have the Spirit of the Knowledge of God. | above | John 7:29
The Messiah would have the Spirit of the Fear of God. | above | Heb. 5:7
The Messiah would have a quick understanding in the fear of the Lord. | Isa. 11:3 | Luke 2:46-47
The Messiah would not judge on the basis of external representations. | above | John 7:24
The Messiah would judge the poor with righteousness. | Isa. 11:4 | Mark 12:41-44
The Messiah would be a descendant of Jesse. | Isa. 11:10 | Luke 3:23-32
The Messiah would come for all people. | above | Acts 13:47-48
The Messiah would have the key of David. | Isa. 22:22 | Rev. 3:7
The Messiah would defeat death. | Isa. 25:8 | Rev. 1:18
Others would rise to life at the resurrection of the Messiah. | Isa. 26:19 | Matt. 27:52-53
The Messiah would be the cornerstone. | Isa. 28:16 | 1Pet. 2:4-6
The Messiah would heal the blind. | Isa. 35:5 | Mark 10:51-52
The Messiah would heal the deaf. | above | Mark 7:32-35
The Messiah would heal the lame. | Isa. 35:6 | Matt. 12:10-13
The Messiah would heal the dumb. | above | Matt. 9:32-33
The forerunner of the Messiah would live in the wilderness. | Isa. 40:3 | Matt. 3:1-4
The forerunner would prepare people for the coming of the Messiah. | above | Luke 1:17
The Messiah would be God. | above | John 10:30
The Messiah would be as a shepherd. | Isa. 40:11 | John 10:11
The Messiah would be God's servant. | Isa. 42:1 | John 4:34
The Messiah would have the Spirit of God upon him. | above | Matt. 3:16-17
The Messiah would please God. | above | Matt. 3:16-17
The Messiah would provide "justice" to the Gentiles. | above | Matt. 24:14
The Messiah would not draw attention to himself. | Isa. 42:2 | Matt. 12:15
The Messiah would have compassion for the poor and needy. | Isa. 42:3 | Matt. 11:4-5
The Messiah would receive guidance from God. | Isa. 42:6 | John 5:19-20
The Messiah would be ministered to by God. | above | John 8:29
The Messiah would be the new covenant. | above | Matt. 26:28
The Messiah would be a light to the Gentiles. | above | John 8:12
The Messiah would heal the blind. | Isa. 42:7 | Matt. 9:27-30
The Messiah would be from everlasting. | Isa. 48:16 | John 1:1-2
The Messiah would be sent from God. | above | John 7:29
The Messiah would come for all people. | Isa. 49:1 | 1Tim. 2:4-6
The Messiah would be called to God's service from the womb. | above | Matt. 1:20-21
The Messiah would be called by his name before he was born. | above | Luke 1:30-31
The Messiah's words would be as a sharp sword. | Isa. 49:2 | Rev. 2:12-16
The Messiah would be protected by God. | above | Matt. 2:13-15
The Messiah would be responsible for the judgment of mankind. | above | John 5:22-29
The Messiah would be God's servant. | Isa. 49:3 | John 17:4
The Messiah's work would glorify God. | above | Matt. 15:30-31
The Messiah would be distressed over the Jews unbelief. | Isa. 49:4 | Luke 19:41-42
The Messiah would be rejected by the Jews. | above | John 5:43
The Messiah would be God's servant. | Isa. 49:5 | John 6:38
The Messiah would come to bring Israel back to God. | above | Matt. 15:24
The Messiah would be God's servant. | Isa. 49:6 | John 12:49-50
The Messiah would be a light to the Gentiles. | above | Acts 13:47-48
The Messiah would be despised. | Isa. 49:7 | John 10:20
The Messiah would speak with knowledge given to him from God. | Isa. 50:4 | John 12:49
The Messiah would not be rebellious to God's will. | Isa. 50:5 | John 12:27
The Messiah's back would be whipped. | Isa. 50:6 | Matt. 27:26
The Messiah's face would be beaten and spit upon. | above | Matt. 26:67
The Messiah would steadfastly set his face toward his mission. | Isa. 50:7 | Luke 9:51-53
The Messiah would be justified by his righteousness. | Isa. 50:8 | 1Tim. 3:16
The Messiah would place his trust in God. | Isa. 50:8-10 | John 11:7-10
The Messiah would be God's servant. | Isa. 52:13 | John 9:4
The Messiah would be highly exalted. | above | Phil. 2:9-11
The Messiah's face would be disfigured from severe beatings. | Isa. 52:14 | Matt. 26:67-68
The Messiahs blood would be shed to make atonement for all. | Isa. 52:15 | Rev. 1:5
The Messiah's own people would not believe he was the Christ. | Isa. 53:1 | John 12:37-38
The Messiah would grow up in a poor family. | Isa. 53:2 | Luke 2:7
The Messiah would have the appearance of an ordinary man. | above | Phil. 2:7-8
The Messiah would be despised. | Isa. 53:3 | Luke 4:28-29
The Messiah would be rejected. | above | Matt. 27:21-23
The Messiah would have great sorrow and grief. | above | Luke 19:41-42
Men would hide from being associated with the Messiah. | above | Mark 14:50-52
The Messiah would have a healing ministry. | Isa. 53:4 | Luke 6:17-19
The Messiah would bear and carry upon himself the sins of the world. | above | 1Pet. 2:24
The Messiah would be thought to be cursed by God. | above | Matt. 27:41-43
The Messiah would bear the penalty for mankind's transgressions. | Isa. 53:5 | Luke 23:33
The Messiah's sacrifice would provide peace between man and God. | above | Col. 1:20
The Messiah's back would be whipped. | Isa. 53:5 | Matt. 27:26
The Messiah would be the sin-bearer for all mankind. | Isa. 53:6 | Gal. 1:4
It was God's will that the Messiah would be the sin-bearer for all mankind. | above | 1John 4:10
The Messiah would be oppressed and afflicted. | Isa. 53:7 | Matt. 27:27-31
The Messiah would be silent before his accusers. | above | Matt. 27:12-14
The Messiah would be as a sacrificial lamb. | above | John 1:29
The Messiah would be confined and persecuted. | Isa. 53:8 | Matt. 26:55
The Messiah would be judged. | above | John 18:13-22
The Messiah would be killed. | above | Matt. 27:35
The Messiah would die for the sins of the world. | above | 1John 2:2
The Messiah would be buried in a rich man's grave. | Isa. 53:9 | Matt. 27:57
The Messiah would be innocent and had done no violence. | above | Mark 15:3
The Messiah would have no deceit in his mouth. | above | John 18:38
It was God's will that the Messiah would die for all mankind. | Isa. 53:10 | John 18:11
The Messiah would be an offering for sin. | above | Matt. 20:28
The Messiah would be resurrected and live forever. | above | Mark 16:16
The Messiah would prosper. | above | John 17:1-5
God would be fully satisfied with the suffering of the Messiah. | Isa. 53:11 | John 12:27
The Messiah would be God's servant. | above | Rom. 5:18-19
The Messiah would justify man before God. | above | Rom. 5:8-9
The Messiah would be the sin-bearer for all mankind. | above | Heb. 9:28
Because of his sacrifice, the Messiah would be greatly exalted by God. | Isa. 53:12 | Matt. 28:18
The Messiah would give up his life to save mankind. | above | Luke 23:46
The Messiah would be grouped with criminals. | above | Luke 23:32
The Messiah would be the sin-bearer for all mankind. | above | 2Cor. 5:21
The Messiah would intercede to God in behalf of mankind. | above | Luke 23:34
The Messiah would be resurrected by God. | Isa. 55:3 | Acts 13:34
The Messiah would be a witness. | Isa. 55:4 | John 18:37
The Messiah would come to provide salvation. | Isa. 59:15-16 | John 6:40
The Messiah would be the intercessor between man and God. | above | Matt. 10:32-33
The Messiah would come to Zion as their Redeemer. | Isa. 59:20 | Luke 2:38
The Messiah would have the Spirit of God upon him. | Isa. 61:1-2 | Matt. 3:16-17
The Messiah would preach the good news. | above | Luke 4:17-21
The Messiah would provide freedom from the bondage of sin and death. | above | John 8:31-32
The Messiah would proclaim a period of grace. | above | John 5:24
Jeremiah |  |
The Messiah would be a descendant of David. | Jer. 23:5-6" | Luke 3:23-31
The Messiah would be God. | above | John 13:13
The Messiah would be both man and God. | above | 1Tim. 3:16
The Messiah would be born of a virgin. | Jer. 31:22 | Matt. 1:18-20
The Messiah would be the new covenant. | Jer. 31:31 | Matt. 26:28
The Messiah would be a descendant of David. | Jer. 33:14-15 | Luke 3:23-31
Ezekiel |  |
The Messiah would be a descendant of David. | Eze. 17:22-24 | Luke 3:31
The Messiah would be a descendant of David. | Eze. 34:23-24 | Matt. 1:1
Daniel |  |
The Messiah would ascend into heaven. | Dan. 7:13-14 | Acts 1:9-11
The Messiah would be highly exalted. | above | Eph. 1:20-22
The Messiah's dominion would be everlasting. | above | Luke 1:31-33
The Messiah would come to make an end to sins. | Dan. 9:24 | Gal. 1:3-5
The Messiah would be holy. | above | Luke 1:35
The Messiah enters Jerusalem 483 years, after the decree to rebuild Jerusalem. | Dan. 9:25 | John 12:12-13
The Messiah would be killed. | Dan. 9:26 | Matt. 27:35
The Messiah would die for the sins of the world. | above | Heb. 2:9
The Messiah would be killed before the destruction of the temple. | above | Matt. 27:50-51
A vision of the Messiah in a glorified state. | Dan. 10:5-6 | Rev. 1:13-16
Hosea |  |
The Messiah would defeat death. | Hosea. 13:14 | 1Cor. 15:55-57
Joel |  |
The Messiah would offer salvation to all mankind. | Joel 2:32 | Rom. 10:12-13
Micah |  |
The Messiah would be born in Bethlehem. | Micah 5:2 | Matt. 2:1-2
The Messiah would be God's servant. | above | John 15:10
The Messiah would be from everlasting. | above | Rev. 1:8
Haggai |  |
The Messiah would visit the second Temple. | Hag. 2:6-9 | Luke 2:27
The Messiah would be a descendant of Zerubbabel. | Hag. 2:23 | Luke 3:27
Zechariah |  |
The Messiah would be God's servant. | Zech. 3:8 | John 17:4
The Messiah would be Priest and King. | Zech. 6:12-13 | Heb. 8:1
The Messiah would be be greeted with rejoicing in Jerusalem. | Zech. 9:9 | Matt. 21:8-10
The Messiah would be beheld as King. | above | John 12:12-13
The Messiah would be just. | above | John 5:30
The Messiah would bring salvation. | above | Luke 19:10
The Messiah would be humble. | above | Matt. 11:29
The Messiah would be presented to Jerusalem riding on a donkey. | above | Matt. 21:6-9
The Messiah would be the cornerstone. | Zech. 10:4 | Eph. 2:20
At the time of Messiah's coming, Israel would have unfit leaders. | Zech. 11:4-6 | Matt. 23:1-4
The Messiah's rejection would cause God to remove His protection of Israel. | above | Luke 19:41-44
The Messiah would be rejected in favor of another king. | above | John 19:13-15
The Messiah would have a ministry to the "poor," the believing remnant. | Zech. 11:7 | Matt. 9:35-36
The unbelief of Israel's leaders would force the Messiah to reject them. | Zech. 11:8 | Matt. 23:33
The Messiah would be despised. | above | Matt. 27:20
The Messiah would stop ministering to the those who rejected Him. | Zech. 11:9 | Matt. 13:10-11
The Messiah's rejection would cause God to remove His protection of Israel. | Zech. 11:10-11 | Luke 19:41-44
The Messiah would be God | above | John 14:7
The Messiah would be betrayed for thirty pieces of silver. | Zech. 11:12-13 | Matt. 26:14-15
The Messiah would be rejected. | above | above
Thirty pieces of silver would be thrown into the house of the Lord. | above | Matt. 27:3-5
The Messiah would be God | above | John 12:45
The Messiah's body would be pierced. | Zech. 12:10 | John 19:34-37
The Messiah would be both God and man. | above | John 10:30
The Messiah would be rejected. | above | John 1:11
It was God's will that the Messiah would die for all mankind. | Zech. 13:7 | John 18:11
The Messiah would die a violent death. | above | Matt. 27:35
The Messiah would be both God and man | above | John 14:9
Israel would be scattered as a result of rejecting the Messiah | above | Matt. 26:31
Malachi |  |
A messenger would prepare the way for the Messiah. | Mal. 3:1 | Matt. 11:10
The Messiah would make a sudden appearance at the temple. | above | Mark 11:15-16
The Messiah would be the messenger of the new covenant. | above | Luke 4:43
The Messiah's forerunner would come in the spirit of Elijah. | Mal. 4:5 | Matt. 3:1-2
The Messiah's forerunner would turn many to righteousness. | Mal. 4:6 | Luke 1:16-17

This list was adapted and edited from a list I found on the Internet somewhere.